Can we really not use Ledger to make posts here? Anything beyond a certain length issues an error.